Image Previews Failing Intermittently
Incident Report for CxAlloy
Resolved
On Monday we rolled out an update that removed our dependence on the 3rd-party image rendering service for our larger image previews, as our provider has not been able to resolve the connection timeouts in a timely manner. This incident is resolved.
Posted Apr 27, 2020 - 02:45 EDT
Identified
Starting Thursday afternoon we observed intermittent issues with image thumbnails and previews not rendering. The source of the issue is the 3rd-party service we use for image resizing, which started to give connection timeouts when our servers requested resized images.

We were able to resolve the issue with image thumbnails by moving the image requests from our server to the browser. In addition, we immediately contacted our 3rd-party provider and we are continuing to work with them on resolving the connection timeouts that are the root of the issue.

Image previews (the larger image view seen when clicking on an image) may not render while we work to resolve this issue. We will continue to update on our progress in resolving this.
Posted Apr 24, 2020 - 13:39 EDT
This incident affected: CxAlloy TQ (Photos and File Previews).