Intermittent Slow Response Times

Incident Report for CxAlloy

Resolved

This incident has been resolved.
Posted May 26, 2026 - 16:35 EDT

Monitoring

Response times have returned to normal. We are continuing to monitor the situation.
Posted May 26, 2026 - 14:21 EDT

Identified

We are seeing an issue with slow response times and occasional timeouts due to load. We have implemented initial corrective measures.
Posted May 26, 2026 - 11:00 EDT
This incident affected: CxAlloy Web Application (Application), CxAlloy iOS App (Sync), and CxAlloy Android App (Sync).