Signature and PDF Markup Errors

Incident Report for CxAlloy

Resolved

This incident has been resolved.
Posted Nov 21, 2025 - 15:15 EST

Monitoring

We have implemented a fix that resolves these issues and are monitoring to ensure no ongoing issues.
Posted Nov 21, 2025 - 10:04 EST

Update

This issue will affect the following:
- Signing a checklist or test signature line or a signature block will fail.
- Attempting to create or update a profile's saved signature will fail.
- When annotating a PDF or image, a red banner showing "503" will appear. The annotation is saved but when generating a report that includes the file the annotation will not be shown.
Posted Nov 21, 2025 - 09:30 EST

Identified

We have identified an issue in the application with saving new signatures and generating updated PDFs when annotations are added. The source of the issue is a component that generates new PDF files on demand returning 503 errors. We are working to resolve the bug and restore service.
Posted Nov 21, 2025 - 09:27 EST
This incident affected: CxAlloy Web Application (Application).